Разработчики Ubuntu объявили о том, что они переводят в разряд устаревших поддержку проприетарного драйвера AMD Catalyst (fglrx), который не войдёт в состав дистрибутива Ubuntu версии 16.04 LTS. Пользователям рекомендуется перейти на использование открытых драйверов AMDGPU/Radeon. Установить драйвер AMD Catalyst с сайта AMD мешает то, что последний выпуск поддерживает работу только с X-server 1.17 и ядрами Linux до 3.19, в то время как в Ubuntu 16.04 задействованы X-server 1.18 и ядро Linux 4.4. Ранее для Ubuntu совместно с AMD готовились специальные сборки драйвера, учитывающие версии компонентов графического стека дистрибутива.

Прекращение поддержки драйвера AMD Catalyst в Ubuntu 16.04 LTS

С учётом развития компанией AMD открытого драйвера AMDGPU, нацеленного на предоставление полноценной поддержки современных графических карт AMD на базе архитектуры GCN, поставка проприетарного драйвера AMD Catalyst имеет смысл только для поддержки старых серий GPU AMD. Проблема в том, что поддержка старых GPU скоро будет удалена из AMD Catalyst - в скором времени будет проведена значительная чистка драйвера, в результате которой будет прекращена поддержка серий Radeon HD 8000 (HD 8400 и ниже), Radeon HD 7000 Series (HD 7600 и ниже), Radeon HD 6000, Radeon HD 5000 и других карт не использующих архитектуру GCN.

Из проблем открытых драйверов, которые со временем планируется устранить в драйверах на базе стека AMDGPU, упоминается отсутствие поддержки OpenGL 4.5 (в открытых драйверах OpenGL 4.1), отставание в производительности при запуске многих игр, неполная поддержка OpenCL, отсутствие поддержки CrossFire multi-GPU. 

Ужасное зрелище конечно, что происходит, что послужило этому причиной, наверное никто этого не узнает. Представьте, допустим, вы используете драйвер fglrx в Ubuntu 14.04 LTS/15.10, и вы планируете перейти на Ubuntu 16.04 в следующем месяце. В процессе обновления к Ubuntu 16.04, автоматически будет удален драйвер fglrx и Xorg.conf.

В зависимости от конкретной аппаратной графики, в Ubuntu 16.04 будет использоваться драйвер с открытым исходным кодом AMDGPU или драйвер с открытым исходным кодом Radeon вместо flgrx.

В данном случае вы можете подумать: "Ну и отлично, я просто напросто переустановлю драйвер сам." Но, вы не сможете этого сделать.

Вы не сможете повторно установить драйвер fglrx/catalyst в Ubuntu 16.04 так как поддержка данного драйвера будет полностью прекращена и удалена с репозиториев, другими словами говоря, после установки Ubuntu 16.04 драйвер fglrx/catalyst прекращает свое существование.

Кроме того, вы не сможете загрузить и установить драйвер fglrx/catalys с использованием  бинарных пакетов с сайта AMD, так как, даже если вы и сможете установить бинарные пакеты, то драйвер более не поддерживает Xorg 1.18 в ubuntu 16.04 xenial xerus.

Ко всему этому Canonical добавила: "Мы не будем поддерживать AMD fglrx на весь период поддержки дистрибутива Ubuntu 16.04 LTS", Canonical не имеет ни малейшего желания взять на себя поддержку fglrx/catalys в течение следующих пяти лет, так как это LTS дистрибутив с сроком поддержки в 5 лет.

Конечно для пользователей(обладателей) видеоадаптеров Nvidia эта новость не имеет никакого интереса, как играли себе спокойно в игрушки так и далее будут играть и нет причин для беспокойства.

Но для пользователей с более старым оборудованием, многие из которых сейчас работают на Ubuntu 14.04 LTS, эта новость заставит задуматься и сделать свой выбор, остаться на 14.04 LTS, так как даже обновившись до версии 16.04 LTS или установив дистрибутив с нуля, и используя при этом видеоадаптер AMD Radeon HD 8000 и ниже не будут иметь поддержки того стабильного стандартного драйвера fglrx/catalys с которым мы все работали в Ubuntu до релиза 16.04 LTS.

Печально конечно это слышать от Canonical, я вот работаю именно на старом видеоадаптере ATI Regeon HD 5450, будем надеяться, что возможно все же что-то поменяется еще до выхода финального релиза Ubuntu 16.04 LTS.

Понравилась статья?
Разработчики Ubuntu объявили о том, что они переводят в разряд устаревших поддержку проприетарного драйвера AMD Catalyst (fglrx), который не войдёт в состав дистрибутива Ubuntu версии 16.04 LTS. Пользователям рекомендуется перейти на использование от...
Мультимедиа
3038
Рейтинг: 5/8
При перепечатке материалов указание ссылки на linuxsoid.com обязательно.

Подпишитесь на рассылку

avatar
1
7 • 23:14,
Живу на 5770, где дрова искать?
avatar
0
8 • 09:44,
Ознакомьтесь с моим ответом в материале - здесь, читайте начиная с скриншота и ниже, это более правильно для ATI / AMD в Linux.  smile
avatar
0
1 • 09:46,
"последний выпуск поддерживает работу только с X-server 1.17 и ядрами Linux до 3.19"
Иксы ладно, а вот с ядром 4.2 норм fglrx работает
avatar
0
2 • 14:34,
Последний выпуск еще не вышел, выйдет в апреле, вы пока работаете на 16.04, но это всего лишь ежедневные сборки и тому подобное, в LTS fglrx уже не будет.
avatar
0
3 • 15:35,
14.04.4 + "последний" fglrx, ядро 4.2+
все работает.
причем тут xerus, если речь о ядрах и каталисте?
avatar
0
4 • 15:48,
Вы наверное невнимательно прочли материал и не не ознакомились с источником - https://wiki.ubuntu.com/XenialXerus/ReleaseNotes#fglrx
avatar
0
5 • 16:08,
мы все же говорим о разном smile

"Установить драйвер AMD Catalyst с сайта AMD мешает то, что последний выпуск поддерживает работу только с X-server 1.17 и ядрами Linux до 3.19"

тогда как он (драйвер) вполне нормально работает на 4-м ядре
avatar
0
6 • 17:19,
аа,  ясн, ну если так то это хорошо, я пока новое ядро не ставил
avatar