Установили Ubuntu 16.04 LTS Xenial Xerus и столкнулись с тем, что в Ubuntu Software невозможно установить приложения с помощью скачанных deb файлов, значит вы такой же счастливчик как и сотни тысяч других пользователей.

Вы столкнулись с сложностью установки приложений формата deb в Ubuntu 16.04 LTS, вы не одиноки с этой проблемой, с ней столкнулись все счастливчики которые установили новый релиз Xenial Xerus.

Ubuntu Software в Ubuntu 16.04 LTS

  • Почитав много отзывов в сети от огромного количества пользователей которые жалуются на то, что они столкнулись с ошибкой при установке таких приложений как Steam, Google Chrome, и Nylas N1, используя для этого .deb файлы. Проблема не лишь с этими приложениями, а всеми которые имеют установочный deb формат.

установка пакета deb в Ubuntu Software

  • При двойном щелчке по файлу данного формата и при нажатии на кнопку установить в новом центре приложений под название Ubuntu Software, вы видите сообщение - "Это стороннее программное обеспечение оно может содержать несвободные компоненты".

Ubuntu Software - ошибка при установке deb программы

При нажатии на кнопку установить пишет уже просто - "Это стороннее программное обеспечение", и происходит отказ от установки.

В общем, с маленькой проблемы выросла огромная, которая всем доставляет лишь неудобство и к всему этому в дополнение, вызывает дополнительные нервы из-за того, что слишком рано перешли на релиз Ubuntu 16.04 LTS, вроде бы все мы понимаем, стабильный релиз, вроде и не должен содержать вот таких мелких, но для удобства установки приложений, серьезных проблем.

На launchpad заведено несколько задач, где разработчики уже подтвердили этот баг, частично поправили, но не полностью, некоторым пользователям помогло, большей части ничем не помогло.

Разработчики советуют просто выполнить следующие команды чтобы установить обновления по фиксу:

sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade
sudo apt-get install gnome-software/xenial-proposed

Но это все же не решает проблему, разработчики как обычно извиняются за доставленные неудобства и просят подождать, вскоре выйдет обновление которое можно будет установить через встроенный менеджер обновлений Software Update, пока ничего еще не вышло, как я вижу по переписке на ланчпаде, обсуждение проблемы все еще актуально и количество жалоб все растет.

Как временное решение пока данный баг исправляют, установить любое необходимое вам приложение можно с помощью терминала, например вы загрузили файл deb в системную папку "Загрузки", для установки файла выполним следующее:

cd ~/Downloads либо cd ~/Загрузки в зависимости от языка системы
sudo dpkg -i name_app.deb
sudo apt-get -f install

Либо же установить пакет GDebi:

sudo apt-get install gdebi

с помощью которого можно установить приложения в формате deb, нажав правой кнопкой мыши по файлу и выбрав в меню - "Открыть в программе" - "Программа установки пакетов GDebi".

Обсудить баг с установкой приложений через deb файлы в Ubuntu Software:

  1. https://bugs.launchpad.net/ubuntu/+source/gnome-software/+bug/1573206
  2. https://bugs.launchpad.net/ubuntu/+source/gnome-software/+bug/1573408

Пока ждем исправлений так как видимо еще долго придется ждать, задача заведена еще 21 апреля, в день выхода релиза 16.04 LTS и еще не исправили.

Понравилась статья?
Установили Ubuntu 16.04 LTS Xenial Xerus и столкнулись с тем, что в Ubuntu Software невозможно установить приложения с помощью скачанных deb файлов, значит вы такой же счастливчик как и сотни тысяч других пользователей. Вы столкнулись с сложностью ус...
How To
5492
Рейтинг: 5/33
При перепечатке материалов указание ссылки на linuxsoid.com обязательно.

Подпишитесь на рассылку

avatar
1
1 • 07:07,
Установка пакета python-support_1.0.14ubuntu2_all.deb - решает эту проблему.По-крайней мере - мне помогла.
avatar