Иногда у нас случается такая ситуация, у нас установлена старая версия приложения, но мы хотим обновить и установить последнюю версию. Пару дней, тому назад и у меня подобное случилось.

Стоит у меня старая версия приложения Webmoney, перешел я на сайт вебмани и увидел, что доступна новая версия, как полагается, загрузил ее и думаю, установлю, в итоге получил я ошибку:

Ошибка при установке пакета Mywm

И в последующем, при попытке установить либо какое приложение я получаю ошибку:

  • E: Пакет mywm нуждается в переустановке, но найти архив для него не удалось. 

Ранее я устанавливал с помощью терминала через простую команду:

dpkg -i ./mywm_1.0.158-1_i386.deb

И все становилось без проблем и новая версия заменяла старую без проблем, а как видите иногда случаются подобные проблемы с пакетами. В официальном сообществе я нашел подобную инструкцию для решения данной проблемы:

  • E: Пакет <имя пакета> нуждается в переустановке, но найти архив для него не удалось

Если у вас выводится такая строка то это решение для вас.
Для решения этой проблемы нужно стереть информацию об этом пакете в файле /var/lib/dpkg/status.
Отредактируйте файл status введя в терминале следующую команду:

sudo gedit /var/lib/dpkg/status

Далее у нас откроется соответствующий файл. Нажмите на CTRL+F и введите поисковый запрос <имя пакета> либо в моей ситуации это пакет MyWm, далее найдите текст ниже и полностью удалите блок:

Package: mywm
Status: install ok installed
Priority: extra
Section: unknown
Installed-Size: 74760
Maintainer: vmuser <pahan40@gmail.com>
Architecture: i386
Version: 1.0.158-1
Depends: libasound2 (>= 1.0.23), libc6 (>= 2.4), libgcc1 (>= 1:4.1.1), libx11-6, libxext6, libxi6, libxrender1, libxtst6
Description: Webmoney keeper for Linux
    My WebMoney - this application for all linux-users of WebMoney!
    Most application for those who are included in your account on the site https://my.webmoney.ru
    Almost all the WebMoney Keeper Mini - now in desktop!
    * Purses & cards
    * contacts & messages
    * convenient payment service
    * Built-in digital goods shop
    * no complicated settings
    * easy to install - a pleasure to use
    P.S. The application is written using WmkApi: https://api4mini.webmoney.ru/
Homepage: <insert the upstream URL, if relevant>

Удалить весь блок информации о пакете. Сохраните.
Примечание: Не удалите ничего лишнего! Введите в терминале следующую команду:

sudo apt-get -f install

Для полной надежности нужно удалить все файлы пакета. Для этого надо установить и удалить этот пакет.

sudo apt-get install <имя пакета> -y && sudo apt-get remove <имя пакета> -y

А как поступил я в данной ситуации, покопавшись в сети наткнулся на подобную проблему, но уже в дистрибутиве Kubuntu и решение достаточно простое, полностью удаляем проблемный пакет с помощью команды:

dpkg -r --force-remove-reinstreq <имя пакета> 

В моем случае это:

dpkg -r --force-remove-reinstreq mywm 

Для большей надежности выполним так же команду:

sudo apt-get -f install
sudo apt-get update

Теперь можете устанавливать заново любое приложение и данной ошибки вы уже не встретите.
Все проблема решена.

Понравилась статья?
Иногда у нас случается такая ситуация, у нас установлена старая версия приложения, но мы хотим обновить и установить последнюю версию. Пару дней, тому назад и у меня подобное случилось. Стоит у меня старая версия приложения Webmoney, перешел я на сай...
Система
4778
Рейтинг: 5/8
При перепечатке материалов указание ссылки на linuxsoid.com обязательно.

Подпишитесь на рассылку

avatar
1
3 • 23:13,
Спасибо..проблема решилась biggrin
avatar
0
ниче не получилось confused huh
avatar
0
2 • 09:58,
Уточни, какая у тебя ошибка и что ты видишь в консоли, скриншот и детально описание приветствуется.
avatar